home *** CD-ROM | disk | FTP | other *** search
/ Just Call Me Internet / Just Call Me Internet.iso / prog / atari / c / ltick03 / makefile.nix < prev    next >
Makefile  |  1993-07-25  |  448b  |  20 lines

  1. # LazyTick Makefile for Unix
  2. # you need strftime, strlwr
  3.  
  4. CC=gcc
  5. CFLAGS=-DUNIX -O
  6.  
  7. # libctext contains strftime and strlwr, which are needed and not in my libc
  8. LDLIBS=-lcext
  9.  
  10. OBJS=tick.o misc.o config.o announce.o crc32.o
  11.  
  12. ltick: $(OBJS)
  13.     $(CC) $(OBJS) $(LDLIBS) -o $@
  14.  
  15. misc.c: misc.h tick.h qbbs.h
  16. config.c: misc.h config.h tick.h
  17. tick.c: config.h misc.h tick.h announce.h crc32.h
  18. announce.c: announce.h tick.h
  19. crc32.c: crc32.h
  20.